wiki:LooPoSnapshot

Version 1 (modified by groessli, 9 years ago) (diff)

--

A snapshot of LooPo is available here: loopo-20081008.tar.bz2. This is not an official release. You need an installation of polylib (http://icps.u-strasbg.fr/polylib/) and Tcl/Tk? to compile LooPo. The Omega library is optional, but some components of LooPo only work when Omega is available (e.g., CfFADA dependence analysis and index set splitting). Use a command similar to the following to configure LooPo:

  ./configure --prefix=$HOME/loopo.installed
      --with-polylib=/public/packages/libraries/polylib-5.22.3 
      --with-tclconfig=/usr/lib/tcl8.4/tclConfig.sh 
      --with-tkconfig=/usr/lib/tk8.4/tkConfig.sh
      --with-omega=/public/packages/libraries/omega1.2_for_loopo-2006-06-27-gcc4.1

Note that you need a patched version of Omega (that fixes compile issues with newer GCCs) which can be found at http://www.infosun.fim.uni-passau.de/cl/loopo/required/.

If you have questions or problems, do not hesitate to contact loopo@infosun.fim.uni-passau.de.